Author Topic: Create Surface - how to prevent 'steps'?  (Read 91 times)

Anthony8

  • Newbie
  • *
  • Posts: 2
Create Surface - how to prevent 'steps'?
« on: September 16, 2021, 02:46:10 AM »
Hi,

I've recently downloaded this toolset and it's wonderful!

One thing, when I use the 'Create Surface (Triangulate)' tool I end up with 'steps' at the contour lines where triangles are formed using three points that are all on the same RL. (see attached image)

Is there a way to prevent this?


Lars

  • Administrator
  • Hero Member
  • *****
  • Posts: 589
Re: Create Surface - how to prevent 'steps'?
« Reply #1 on: September 18, 2021, 08:48:43 PM »
Hi,

Triangulate contours might give you odd results. You need to prevent the creation of triangles that have same elevation on all three vertices. Since there is no such option in CadTools you need provide som extra lines that might force the triangulation to get only two vertices with same elevation.

  • Try to generate perpendicular lines between contours by using "Lines, Transverse Lines Between Polylines".
  • Set Minor Tick Size to 100% and a relative small Horizontal interval, a value smaller than the distance between vertices in any contour line.
  • When you triangulate be sure to set "Use lines as breaklines" to All Active Layers (DropDown). Set triangle output to "Drawing".

You can edit any triangle in the drawing manually as long you don't flip them (all triangles must have same point order, clockwise or anticlockwise). After editing you can select by crossing and save them to file (Saving to file is available in File menu in booth "Create Surface" and "Edit/View Surface"

/Lars
« Last Edit: October 13, 2021, 12:25:14 PM by Lars »

Anthony8

  • Newbie
  • *
  • Posts: 2
Re: Create Surface - how to prevent 'steps'?
« Reply #2 on: October 13, 2021, 12:31:32 AM »
Hi,

Thank you for your response, those are some great tips, I'll be sure to use them next time :).